Discussion

Weird thing happens whenever I run a project (Windows).

0

Kierham 2020-10-24 19:14

I normally use iOS to code because of this glitch. Whenever I use a tool (Character Designer, Sound Composer, BG Designer) then go back to the .nx file in notepad, all the code is put into a single line. It's also impossible for me to show you a screenshot because it is too big, or too small. Please fix these 2 problems.


Timo 2020-10-24 20:28

This is because it saves the text file in Mac/Linux format. Windows uses a different code for new lines.
But you can use other tools on Windows, which support all codes. You can try Notepad++ for example. It's free.


Kierham 2020-10-24 20:55

Thanks!


Kierham 2020-10-24 21:10

I am using notepad, and Timo already solved my problem.


GAMELEGEND 2020-10-24 21:15 (Edited)

yeah I know, I dont know why I typed that

but the thing I dont understand is when you use a tool notepad puts it on one line
but for me it looks like its supposed to


Timo 2020-10-24 22:03

LowRes NX can read both “new line” codes (mac and windows), but only writes the mac code when saving.

So if you open the file on a simple Windows text editor, it will not understand the “new line” code and it shows everything in one line.

Notepad++ and other more professional text editors understand both codes.


nathanielbabiak 2020-10-25 01:10

Within Notepad++, you can use the menu toolbar, Edit --> EOL Conversion --> Windows (CR LF). Just do that after you use any of the LowRes NX tools, and it'll give you the line breaks you need.


G-9 2020-10-25 18:59

Don’t worry, its the same for all Windows users ;)


Log in to reply.